Wireguard fungerar inte sen några dagar?

Vår huvudtjänst.
Integirty
Inlägg: 9
Blev medlem: lör 9 maj 2020, 12:57

Wireguard fungerar inte sen några dagar?

Inlägg av Integirty » sön 13 september 2020, 09:14

Hej!

Wireguard verkar inte fungera längre för mig. Den fastnar på "Handshake did not complete after 5 seconds". Jag har testat att skapa en ny konfigurationsfil, men det blir ingen skillnad.

Kod: Markera allt

2020-09-13 09:08:35.978: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:08:35.980: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Awaiting keypair
2020-09-13 09:08:36.076: [TUN] [integrity_vpn] Monitoring default v6 routes
2020-09-13 09:08:36.076: [TUN] [integrity_vpn] Binding v6 socket to interface 0 (blackhole=true)
2020-09-13 09:08:36.076: [TUN] [integrity_vpn] Setting device v6 addresses
2020-09-13 09:08:36.172: [TUN] [integrity_vpn] Listening for UAPI requests
2020-09-13 09:08:36.172: [TUN] [integrity_vpn] Startup complete
2020-09-13 09:08:41.201: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:08:46.202: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:08:51.220: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:08:56.287: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:01.452: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:06.583: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:11.662: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Handshake did not complete after 5 seconds, retrying (try 2)
2020-09-13 09:09:11.662: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:16.687: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:21.734: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:26.869: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:31.870: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:36.898: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:41.955: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Sending handshake initiation
2020-09-13 09:09:47.064: [TUN] [integrity_vpn] peer(ipW9…4PQY) - Handshake did not complete after 5 seconds, retrying (try 2)

epostaren
Inlägg: 5
Blev medlem: lör 8 februari 2020, 18:43

Re: Wireguard fungerar inte sen några dagar?

Inlägg av epostaren » sön 13 september 2020, 12:00

Funkar inte för mig heller sedan i fredags kväll. OpenVPN fungerar som det ska.

TeeKay2000
Inlägg: 7
Blev medlem: fre 29 november 2019, 20:38

Re: Wireguard fungerar inte sen några dagar?

Inlägg av TeeKay2000 » sön 13 september 2020, 12:17

Var detta efter en windows update?
En bekant har fått samma problem nämligen och vi försöker se vad som skiljer.

Integirty
Inlägg: 9
Blev medlem: lör 9 maj 2020, 12:57

Re: Wireguard fungerar inte sen några dagar?

Inlägg av Integirty » sön 13 september 2020, 12:26

Windows update körs ju hela tiden så det är svårt att veta. :/

TeeKay2000
Inlägg: 7
Blev medlem: fre 29 november 2019, 20:38

Re: Wireguard fungerar inte sen några dagar?

Inlägg av TeeKay2000 » sön 13 september 2020, 12:48

Kanske är ett fel med själva tjänsten.
Vad vi märkt är att, på en enhet där Wireguard är igång och fungerar, deaktiverar du den och försöker aktivera igen så kommer inte handskakning lyckas.

Tjänsten har ju haft lite problem på sistone så kan ju vara kopplad till det.


Edit: Verkar fungera igen.

Markus
Inlägg: 81
Blev medlem: tor 10 januari 2019, 12:17
Ort: Stockholm

Re: Wireguard fungerar inte sen några dagar?

Inlägg av Markus » mån 14 september 2020, 10:37

Vi har inga problem med tjänsten vad jag kan se.
Om du inte lyckas få någon handshake så skulle det tyda på något typ av nät/uppkopplings problem.

observera att du max kan ha 5 aktiva konfigurationsfiler. försöker du skapa fler så kommer systemet ersätta din äldsta konfiguration/nyckel. Detta skulle kunna ge handshake problem om du försöker ansluta med en gammal konfigurationsfil.

epostaren
Inlägg: 5
Blev medlem: lör 8 februari 2020, 18:43

Re: Wireguard fungerar inte sen några dagar?

Inlägg av epostaren » mån 14 september 2020, 13:57

Idag fungerar det för mig igen...

Integirty
Inlägg: 9
Blev medlem: lör 9 maj 2020, 12:57

Re: Wireguard fungerar inte sen några dagar?

Inlägg av Integirty » ons 16 september 2020, 21:06

Fungerar igen för mig också. Märkligt.

Integirty
Inlägg: 9
Blev medlem: lör 9 maj 2020, 12:57

Re: Wireguard fungerar inte sen några dagar?

Inlägg av Integirty » tor 17 september 2020, 12:55

Det fungerar att komma ut, men det är mycket segt av och till. Vissa sidor är sirap-sega och andra är OK. Stänger jag av Wireguard är det full fart hela tiden.

EDIT: Det visar sig att om man ersätter IP-adresserna med egen local DNS på DNS-raden i profilen så segar det sig. Lösning är att kommentera bort DNS-raden helt istället.

Skriv svar