WireGuard på Ubuntu = jättesegt. Inget problem på Windows

Vår huvudtjänst.
exo89
Inlägg: 7
Blev medlem: tor 12 mars 2020, 22:09

WireGuard på Ubuntu = jättesegt. Inget problem på Windows

Inlägg av exo89 » tor 4 juni 2020, 22:11

Hej!
Varför går WireGuard så otroligt segt på Ubuntu 18.04? Installerat enligt anvisningarna, ansluter och får långa svarstider på hemsidor och nedladdning av spel på t.ex Steam går i max 120KB/s.
Så fort jag kopplar ned WireGuard återgår hastigheten till det vanliga så det borde inte vara något problem med portar/brandvägg?

På Windows går det alldeles utmärkt att surfa/ladda ned spel på Steam när man är ansluten till WireGuard.

För att göra saken mer förvirrande verkar detta inte alls påverka torrenttrafik. Går jättesnabbt att ladda ned ISO's på diverse distros, men trafik via webbläsare samt Steam kryper fram som sirap. Med eller utan torrentnedladdning i bakgrunden.

gostal
Inlägg: 12
Blev medlem: sön 24 maj 2020, 09:55

Re: WireGuard på Ubuntu = jättesegt. Inget problem på Windows

Inlägg av gostal » fre 5 juni 2020, 13:50

Håller med. När jag kopplar upp wireguard på Mint 19.1 (baskod Ubuntu 18.04) så går det segt som tusan med surfningen. När jag igår kväll provade mäta på https://www.speedtest.net/ så tog det låååång tid innan downloadmätningen kom igång men då snurrade det på i ca 85 Mbit/s och jag har Bahnhof 100/100. Uploadmätningen däremot kom aldrig igång utan timade ut. Med speedtest-cli på kommandoraden så gick det att mäta men resultatet blev bara några fjuttiga Mbit/s åt vardera hållet. Och som du säger, på Windows 10 inget problem varken med surfning eller mätning, se
viewtopic.php?f=2&t=410&start=10#p1437.
Kommer att kolla lite nu och då för att se om det blir någon ordning på det men tills dess kommer jag hålla mig till openvpn på Linux.

gostal
Inlägg: 12
Blev medlem: sön 24 maj 2020, 09:55

Re: WireGuard på Ubuntu = jättesegt. Inget problem på Windows

Inlägg av gostal » fre 5 juni 2020, 14:02

Sökte lite på problemet men fick inga träffar alls. Kanske är det något trassel men Integritys server. Det skulle eventuellt oxå kunna förklara varför jag inte fick skriptet för att skapa konfiguration från egen nyckel att fungera.

gostal
Inlägg: 12
Blev medlem: sön 24 maj 2020, 09:55

Re: WireGuard på Ubuntu = jättesegt. Inget problem på Windows

Inlägg av gostal » fre 12 juni 2020, 11:56

Kan vara så att Ubuntu gjort något tokigt med backporten av wireguard. Igår kom det en uppdatering men tyvärr funkade den inte på Mint 19.1 pga någon inkompatibilitet med kärnan. Jag har inte försökt installera om än. Eventuellt kommer en ny patch rätt vad det är.

Hittade förresten någon tråd om segt wireguard på linux. Orsaken var dåligt satt MTU-värde men det var för flera år sedan så det kan knappast vara relevant nu.

gostal
Inlägg: 12
Blev medlem: sön 24 maj 2020, 09:55

Re: WireGuard på Ubuntu = jättesegt. Inget problem på Windows

Inlägg av gostal » lör 13 juni 2020, 01:22

Visade sig att anledningen att uppdateringen inte gick in var att kärnan jag körde på hade blivit för gammal. Datorn hade väl varit igång någon månad eller två.
Jag började med att rensa ut wireguard:

Kod: Markera allt

sudo apt remove wireguard-dkms
sudo apt remove --purge wireguard-dkms
sudo apt autoremove
det sista för att det kom ett tips om att en del paket blvit obsoleta
Startade sedan om och hittade tre nyare kärnor än den jag körde på och lät datorn starta på den senaste. Installerade om med

Kod: Markera allt

sudo apt install wireguard
och då tog programmet sig för att installera än ännu nyare kärna samt headers. Hela installationen gick igenom smärtfritt och det gick bra att starta wireguard men trist nog fortfarande extremt segt så fortfarande är det openvpn som gäller för mig. Kärnan som wireguard tog med sig är

Kod: Markera allt

5.3.0-1026-gke
och den senaste jag hade vid omstarten var

Kod: Markera allt

4.15.0-106-generic

gostal
Inlägg: 12
Blev medlem: sön 24 maj 2020, 09:55

Re: WireGuard på Ubuntu = jättesegt. Inget problem på Windows

Inlägg av gostal » lör 13 juni 2020, 18:19

Verkar som Ubuntu strulat till det ordentligt. Generation 5-kärnan som wireguard drog med sig lirar inte med vissa av modulerna till den senaste Mint 19.1 kärnan 4.15.0-106-generic så kör jag den kärnan funkar inte ljudet och kanske inte vissa andra saker heller men jag kan starta wireguard, ett tills vidare tveksamt nöje för det går segt som tusan jfrt med openvpn. Startar jag istället med 4.15.0-106-generic så funkar all hårdvara men det finns ingen wireguard-modul. :(

Skriv svar